The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

dmvaldman (2) [Avatar] Offline
#1
I was getting a permissions error upon accessing http://widget.dev etc, until I also included:

<Directory "/Users/username/project/">
Options Indexes MultiViews Includes
AllowOverride All
Order allow,deny
Allow from all
</Directory>

in my httpd.conf file, in addition the code in the book:

<VirtualHost *:80>
ServerName publisher.dev
DocumentRoot "/Users/username/project/publisher"
</VirtualHost>
<VirtualHost *:80>
ServerName widget.dev
DocumentRoot "/Users/username/project/widget"
</VirtualHost>

I'm new to this, and this change fixed it. Perhaps you could shed light on what happened.
benvinegar (68) [Avatar] Offline
#2
Re: 2.1.3 Forbidden 403 Error
You're right. Depending on your Apache configuration, you may need to additionally specify <Directory> directives for those paths.

On my OS X machine, which had a basic Apache configuration in place, some default rules were already in place.

- Ben