The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

fantato (3) [Avatar] Offline
Hello guys,

I am trying to run the example in Chapter 10 but it only work with the regular form types. If I try to use the types: "user" or "textarea". I get this exception:

Caused by: org.activiti.engine.ActivitiException: unknown type 'user' | org/activiti/explorer/demo/process/testProcess.bpmn20.xml | line 12 | column 92
unknown type 'textarea' | org/activiti/explorer/demo/process/testProcess.bpmn20.xml | line 15 | column 88

at org.activiti.engine.impl.util.xml.Parse.throwActivitiExceptionForErrors(
at org.activiti.engine.impl.bpmn.parser.BpmnParse.execute(
at org.activiti.engine.impl.bpmn.deployer.BpmnDeployer.deploy(
at org.activiti.engine.impl.persistence.deploy.DeploymentCache.deploy(
at org.activiti.engine.impl.persistence.deploy.DeploymentCache.resolveProcessDefinition(
at org.activiti.engine.impl.persistence.deploy.DeploymentCache.findDeployedProcessDefinitionById(
at org.activiti.engine.impl.cmd.GetStartFormCmd.execute(
at org.activiti.engine.impl.cmd.GetStartFormCmd.execute(
at org.activiti.engine.impl.interceptor.CommandExecutorImpl.execute(
at org.activiti.engine.impl.interceptor.CommandContextInterceptor.execute(
at org.activiti.engine.impl.interceptor.LogInterceptor.execute(
at org.activiti.engine.impl.FormServiceImpl.getStartFormData(
at org.activiti.explorer.ui.process.listener.StartProcessInstanceClickListener.buttonClick(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at com.vaadin.event.ListenerMethod.receiveEvent(
... 22 more

Do you have any idea to fix it? I already try to get the source code form activiti-explorer and implements the examples from scratch, but I got the same error.

tijs.rademakers (494) [Avatar] Offline
Re: Exception trying to run the example in Chapter 10 (Custom Forms)
Hi Fantato,

That the user type is not working is really strange, because that's already available when you download Activiti 5.9. Which version of Activiti are you running? Are you running the Activiti Explorer webapp as it is installed in the Activiti setup script?
When do you het the exception as shown in your post?
I just deployed a process definition with a user form type without any problem.

Best regards,
fantato (3) [Avatar] Offline
Re: Exception trying to run the example in Chapter 10 (Custom Forms)
Regarding the activiti, I am using the version 5.9. For running the custom forms explained on chapter 10, I tried two options:

First, I got the latest version of book sample sources and I was trying to run the book-explorer-form.

Next, I got the original activiti-explorer source code and I did all steps from this chapter. But, I got the same error.

The exception has been thrown when I start the process and the engine enters will render the form.

It is really a very strange bevahior. I will try to get the source code again, maybe my environment was compromised. I let you know if it works or not.

fantato (3) [Avatar] Offline
Re: Exception trying to run the example in Chapter 10 (Custom Forms)
I got the entire code of activiti-webapp-explorer2 from svn repository and I did the exercise again. It works fine.

I guess the problem was that the example book-explorer-form has some missing files. If you use it as starting point, it will not work. But if you use the original source code, it is ok.

Thanks for your help