MikB (202) [Avatar] Offline
#1
When I follow the instructions I get a "java.net.MalformedURLException: no protocol: /[MyDomainName]-norwegian-language-addon/target/se.[MyDomainName].addons.i18n.norwegian-0.1.0.BUILD-SNAPSHOT.jar" at the osgi start command. The project builds fine.

All this in Roo 1.2m1.

If I don't use my own domain and use the exact wording from the book I get "Execution sign-artifacts of goal org.apache.maven.plugins:maven-gpg-plugin:1.3:sign failed. NullPointerException " as I haven't registered any key with that domain.
MikB (202) [Avatar] Offline
#2
Re: language addon fails with java.net.MalformedURLException
The instructions are those in version 9: Section "5.2.8 What if my Locale Doesn't Exist?" physical page 177 (logical page 173).

The complete error message is 'java.net.MalformedURLException: no protocol: /Users/mik/Documents/Kodkrigaren/Java/STS-2.8.1/[MyDomainName]-norwegian-language-addon/target/se.[MyDomainName].addons.i18n.norwegian-0.1.0.BUILD-SNAPSHOT.jar
Bundle ID /Users/mik/Documents/Kodkrigaren/Java/STS-2.8.1/[MyDomainName]-norwegian-language-addon/target/se.[MyDomainName].addons.i18n.norwegian-0.1.0.BUILD-SNAPSHOT.jar is invalid." '
nancom (12) [Avatar] Offline
#3
Re: language addon fails with java.net.MalformedURLException
i think you need to use command like this

osgi start --url file://{your jar file}
MikB (202) [Avatar] Offline
#4
Re: language addon fails with java.net.MalformedURLException
I'm not sure why you would assume I didn't use the osgi start command, as that is listed on the page I refered to.