ivank2139 (3) [Avatar] Offline
#1
I have been working with Spring Roo and tried using the jdk1.7.0. It does not work! I got a lot of errors that seemed to point to the aspectj compiler.

I reset the environment and used jdk1.6. and it all worked fine. I think this has to be done before any roo generation occurs. I think what happens is that if the jdk is set to 1.7 then roo generates a pom that references 1.7 for source and target. If the jdk is at 1.6 it will generate references to 1.6 code.

I think it means that Roo's use of the jdk version setting is incomplete in that the pom generation is mostly correct but the other parts like the aspectj compiler are not.
ken.rimple (246) [Avatar] Offline
#2
Re: Jdk1.7
I am not surprised. The AspectJ compiler is modifying bytecode. Any change to the configuration of bytecode is going to break that.

Keep in mind Spring 3.1 will support Java 7, and Roo does not yet use Spring 3.1 as it is not GA.

I would assume the release of 1.2 or a later release would be Java 7 compliant.

Ken
MikB (202) [Avatar] Offline
#3
Re: Jdk1.7
Ivan, have you reported this as a bug at https://jira.springsource.org/browse/ROO?
ivank2139 (3) [Avatar] Offline
#4
Re: Jdk1.7
I have not. I will do so in the morning or by the weekend. Thank you for reminding me.
jbbarquero (84) [Avatar] Offline
#5
Re: Jdk1.7
The problem is related to the Felix framework. You can download the version 4.01 and it seems to work, as appear at http://forum.springsource.org/showthread.php?113632-Error-staring-the-Roo-shell

There are at least a couple of JIRA tickets. The problem seems to be solved in the next version: 1.2. See:

https://jira.springsource.org/browse/ROO-2713

https://jira.springsource.org/browse/ROO-2622
MikB (202) [Avatar] Offline
#6
Re: Jdk1.7
So far I've seen few reasons to not update to the prerelease and nightly versions of Roo, so I've been on 1.2 for a while. Even taking a midproject downday have been worth it, at least as a learning experience.