This topic is READ ONLY
sandefan (39) [Avatar] Offline
#1
After running the Ubuntu installer, with Ubuntu 10.04.1 (Lucid) the same problems occur as did in Ubuntu
Karmic (see http://www.manning-sandbox.com/thread.jspa?messageID=98222𗾮smilie. Lucid still has the ancient
old error prone pythoncard-0.8.1
With Lucid, the solution now is (in my experience):

* Using synaptic package manager remove "wxgtk2.6..." and "pythoncard..."
* keep or install python- wxgtk2.8.10 using pacjage manager
* download PythonCard-0.8.2.tar.gz from http://pythoncard.sourceforge.net/
* unpack: $ tar -zxvf PythonCard-0.8.2.tar.gz
* switch to the new directory PythonCard-0.8.2
* $ sudo python setup.py install

This does it. Phew!

Cheers,

sandefan

Message was edited by:
sandefan

Message was edited by:
sandefan
sandefan (39) [Avatar] Offline
#2
Ubuntu 10.04.1: where are the pythoncard tools?
here (in my pythoncard-installation, built from source, see previous posting):

/usr/local/lib/python2.6/dist-packages/PythonCard/

make the tools, such as resourceEditor.py executable, and link them to your menu 'Applications/Programming/', e.g.

/usr/local/lib/python2.6/dist-packages/PythonCard/tools/resourceEditor/resourceEditor.py

Message was edited by:
sandefan

Message was edited by:
sandefan
warren.sande (211) [Avatar] Offline
#3
Re: Linux-Ubuntu 10.04.1 (Lucid Lynx): this is how it works with Hello World!
Did you try the HelloWorld Linux installer?

http://www.manning.com/sande/installers/hello_world_ubuntu.tar.gz


Warren Sande
sandefan (39) [Avatar] Offline
#4
Re: Ubuntu 10.04.1: where are the pythoncard tools?
Of course, I tried the Hello World installer first. In Ubuntu (up to the present version 10.04.1, Lucid), it installs the only pythoncard present, pythoncard0.8.1, that is dependent on wxgtk2.6. The up-coming Ubuntu version Maverick has pythoncardcard0.8.2, but a version that is also dependent on wxgtk2.6 smilie