jzhang (2) [Avatar] Offline
#1
Hi, I am reading chapter 10 to try Pure Master and Slave topology. I am using AMQ 5.3.2 and set up two simple brokers on a Linux VM host. I did not do anything on the master (lab-1:61613). I added following line to slave's activemq.xml:

<services>
<masterConnector remoteURI="failover://(tcp://lab-1:61613)" userName="system" password="manager" />
</services>

....

<transportConnectors>
<transportConnector name="openwire" uri="tcp://${host.name}:${port}"/>
</transportConnectors>
....

Then I started master, few sec later I started slave one. But the log from slave keep showing:

2010-07-28 11:12:52,237 | DEBUG | Connect fail to: tcp://lab-1:61613, reason: java.net.ConnectException: Connection refused | org.apache.activemq.transport.failover.FailoverTransport | ActiveMQ Task

What is the problem? Also the slave can not be shutdown using actvemq-admin command.

Thanks,

-J
jzhang (2) [Avatar] Offline
#2
Re: I need a simple example to configure Pure master and slave
I got it resolved, it needs full qualified DNS name for the master:

services>
<masterConnector remoteURI="failover://(tcp://lab-1.mycompany.com:61613)" userName="system" password="manager" />
</services>

-J
12422 (2) [Avatar] Offline
#3
I need a simple example to configure Pure master and slave. This is now deprecated
This is now deprecated. See http://activemq.apache.org/pure-master-slave.html. So you can ignore paragraph 10.1.1.
447387 (1) [Avatar] Offline
#4
I really happy to find your article and i have felling good after read this post because it providing good information. Thank you for sharing this article. I am working in cash back shopping website company.Thank you so much! Such an honor! Thanks for having this site