The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

pcroser (21) [Avatar] Offline
#1
I think in error I posted this in the wrong forum.

Referring to the zip file osesbinaction-full-environment.zip it unzips fine.
When I attempt to run ant (version 1.6.5 ) , I get the following error

get-servicemix:
[echo] Downloading ServiceMix.... (77MB)
[get] Getting: http://apache.nedmirror.nl/servicemix/servicemix-3/3.2.1//apache-servicemix-3.2.1.zip
[get] To: /osesbinaction/work/downloads/apache-servicemix-3.2.1.zip

get-servicemix:
[echo] Downloading ServiceMix.... (77MB)
[get] Getting: http://apache.nedmirror.nl/servicemix/servicemix-3/3.2.1//apache-servicemix-3.2.1.zip
[get] To: /osesbinaction/work/downloads/apache-servicemix-3.2.1.zip

Can anyone help with this issue.
pcroser (21) [Avatar] Offline
#2
Re: Using osesbinaction-full-environment.zip, the ant script fails
I updated the Ant Version to a version above 1.7 which I missed in the instructions.
Now I got futher it ran for some time before it failed Looks like a failure trying to get ServiceMix.

Any help would be appreciated.

get-servicemix:
[echo] Downloading ServiceMix.... (77MB)
[get] Getting: http://apache.nedmirror.nl/servicemix/servicemix-3/3.2.1//apache-servicemix-3.2.1.zip
[get] To: /osesbinaction/work/downloads/apache-servicemix-3.2.1.zip
[get] Error getting http://apache.nedmirror.nl/servicemix/servicemix-3/3.2.1//apache-servicemix-3.2.1.zip to /osesbinaction/work/downloads/apache-servicemix-3.2.1.zip
pcroser (21) [Avatar] Offline
#3
Re: Using osesbinaction-full-environment.zip, the ant script fails
Users will have to modify the script items to point ot older versons Apache uses the following for previous versions.

http://archive.apache.org/dist/opensourceproduct
You must change the source address for the following
apache-ode-jbi-1.2.zip
servicemix-3.2.1
james-binary-2.3.1.zip
openejb-3.0.zip