bpmm (34) [Avatar] Offline
#1
Hi,
I am beginning to develop with PHP and zendFramework then I use aptana IDE 2.0 which has integrate php 5.x. I have began to create project with differents layers and make copy files examples one by one but when I run application in order to test I get an error message which require these files:
- Warning: require_once(Zend/Loader.php) [function.require-once]: failed to open stream: No such file or directory in C:...
- Fatal error: require_once() [function.require]: Failed opening required 'Zend/Loader.php' (include_path='C:.....

But where I take this function "Zend/loader"? Do you help me in order to success this test?
Because I don't see this file in provide repository with examples.
Best regards,
bpmm
akrabat (479) [Avatar] Offline
#2
Re: Run example of Chap. 2 but where is "Zend/Loader.php" ????
Zend/Loader.php was removed in an earlier version of Zend Framework. If you are starting out now, then I recommend starting with http://akrabat.com/zft

Regards,

Rob...
bpmm (34) [Avatar] Offline
#3
Re: Run example of Chap. 2 but where is "Zend/Application.php" ????
Hi,
I have take example of source code on zf-tutoriel but I have two difficult such as:

- Debug Warning: /zendPHP/helloworld/public/index.php line 17 - require_once(ZendPHP/Application.php): failed to open stream: No such file or directory
Compile Error: /zendPHP/helloworld/public/index.php line 17 - require_once(): Failed opening required 'ZendPHP/Application.php' (include_path='C:UsersMFOUKA MOKONOMy DocumentsAptana RadRails WorkspacezendPHPhelloworldlibrary;.;C:UsersMFOUKA MOKONOMy DocumentsAptana RadRails WorkspacezendPHP')
PHP Warning: Module 'ftp' already loaded in Unknown on line 0
PHP Warning: Module 'json' already loaded in Unknown on line 0

- Debug Error: /zendPHP/helloworld/public/index.php line 20 - Class 'Zend_Application' not found

Where is the 'Zend/Application.php' and the class 'Zend_Application' ?
What's used to solve this situation, firstly get or implement Application.php and secondly get or implement Zend_Application class?
regards,
bpmm
akrabat (479) [Avatar] Offline
#4
Re: Run example of Chap. 2 but where is "Zend/Application.php" ????
Which version of Zend Framework are you using?

Regards,

Rob...
bpmm (34) [Avatar] Offline
#5
Re: Run example of Chap. 2 but where is "Zend/Application.php" ????
Hi,
I am using PHP 5.3.0 and Zend CE features 5.3.7 under aptana IDE 2.0.
regards
akrabat (479) [Avatar] Offline
#6
Re: Run example of Chap. 2 but where is "Zend/Application.php" ????
The Zend Framework version number will be a 1.x number
bpmm (34) [Avatar] Offline
#7
Re: Run example of Chap. 2 but where is "Zend/Application.php" ????
Hi,
I think that php 5.3.0 and zend CE are sufficient to develop under zend framework with aptana IDE 2.0. But if I must add zend framework under aptana ide, how do it do?
Instead that I have added under aptana ide a PDT 2. which to develop with PHP 5.3.0.
best regads
bpmm (34) [Avatar] Offline
#8
install eclipse-php-galileo ????
Hi,
I am thinking another solution which consist to install eclipse-php-galileo 3.5 IDE in order to develop PHP with ZendFramework, is it good solution to replace aptana studio?
I want to obtain response at this problem for goals to continue worked on zend framework under php.
regards
akrabat (479) [Avatar] Offline
#9
Re: install eclipse-php-galileo ????
The choice of IDE does not affect your use of Zend Framework.

Have you gone through my tutorial at http://akrabat.com/zft or the Quick Start at http://framework.zend.com/docs/quickstart ?

Regards,


Rob...
bpmm (34) [Avatar] Offline
#10
Re: install eclipse-php-galileo ????
Hi,
Yes I visited the sites web with links that given in your last responses.
regards
bpmm (34) [Avatar] Offline
#11
what's the good IDE ????
Hi,
I would know it's obliged to add library or plugin ZendFrameWork under aptana or eclipse IDE in order to develop applications with PHP 5.3 zendframework. Supposing this use case, how do it to integrate zendframework in IDE??
best regards