nkatoch2001 (35) [Avatar] Offline
#1
Hi all,

I am getting the following error:-
cd C:forGlassFishEJB3glassfishchapter4

C:forGlassFishEJB3glassfishchapter4>ant
Buildfile: build.xml

common:
[echo] BuildName: chapter4
[echo] BuildHome: C:forGlassFishEJB3glassfishchapter4
[echo] BuildFile: C:forGlassFishEJB3glassfishchapter4uild.xml
[echo] BuildJVM: 1.6

java-env-check:

init:
[echo] -----> Initializing project properties

setup:
[echo] -----> Creating the required sub-directories

compile-ejb-classes:
[echo] -----> Compiling EJBs

ejb-descriptor:

package-ejb:
[echo] -----> Create EJB jar file

compile-cli-classes:

cli-descriptor:

package-client:

package-app:

deploy:
[echo] asadmin.bat deploy --user admin --password adminadmin --host localhost --port 4848 --upload=true lib/chapter4.ear
[exec] Command deploy executed successfully.

all:
[echo] -----> Creates and deploys all deployable units for the application

BUILD SUCCESSFUL
Total time: 11 seconds
C:forGlassFishEJB3glassfishchapter4>ant run
Buildfile: build.xml

common:
[echo] BuildName: chapter4
[echo] BuildHome: C:forGlassFishEJB3glassfishchapter4
[echo] BuildFile: C:forGlassFishEJB3glassfishchapter4uild.xml
[echo] BuildJVM: 1.6

java-env-check:

init:
[echo] -----> Initializing project properties

run:
[echo] Executing client class using C:EXAMPLES_HOMEglassfish/bin/appclient.bat
[exec] Dec 18, 2009 4:58:36 PM com.sun.messaging.jmq.jmsclient.ExceptionHandler throwConnectionException
[exec] WARNING: [C4003]: Error occurred on connection creation [naveen.gateway.2wire.net:7676]. - cause: java.net.UnknownHostException: naveen.gateway
.2wire.net

Any input will be appreciated.

Thanks for your time,

Naveen
nkatoch2001 (35) [Avatar] Offline
#2
Re: Problem running ant script of chapter 4 using glassfish sever 2.1
I fixed it by changing the entry in C:EXAMPLES_HOMEglassfishdomainsdomain1configdomain.xml

<jms-service addresslist-behavior="random" addresslist-iterations="3" default-jms-host="default_JMS_host" init-timeout-in-seconds="60" reconnect-attempts="3" reconnect-enabled="true" reconnect-interval-in-seconds="5" type="EMBEDDED">
<jms-host admin-password="admin" admin-user-name="admin" host="localhost" name="default_JMS_host" port="7676"/>
</jms-service>

Thanks,

Naveen