lostCoder (2) [Avatar] Offline
#1
Hi,

I've been running into this error all over the place in almost every tutorial I try. I have tried on ubuntu and on windows 7 and the error is the same. Something I must be missing to use rake. Is there another way to accomplish the same thing?

C:UsersEvanBitNami RubyStack projectspomodo>newdb.bat

C:UsersEvanBitNami RubyStack projectspomodo>mysql -h localhost -u root -p 0
<dbcreate.sql >
Enter password: *******

C:UsersEvanBitNami RubyStack projectspomodo>call rake db:migrate
(in C:/Users/Evan/BitNami RubyStack projects/pomodo)
rake aborted!
Access denied for user 'pomodo'@'localhost' (using password: YES)
ormation (1) [Avatar] Offline
#2
Re: rake db:migrate error
I have exactly the same error on Windows XP sp3. I noticed that the command "mysql -h ... -p" fails if the mysql server is shut off in Windows services. Of course. What client no server? smilie I restarted the mysql server windows services, entered "mysql -h ...-p" on the command line, then entered all the commands in create.sql with no problem. Then I quit the mysql client, the service is still running, and then entered "call rake db:migrate" on the command line and got the exact same error. It appears that something in rake is failing to make a connection to the mysql server. Perhaps it's a problem with the mysql installation/configuration?

Any ideas?