tempusfugit (130) [Avatar] Offline
#1
Minor typo 6.7.2 (p.169)

There is no "p" variable in the query expression only "c", so it should be:
[pre]
var names = from c in places
where 1000000 < c.Population
select c.Name;
[/pre]


6.7.3 (p.170)
Binding uses "foldLeft" as a name while the type signature reported is for "fold_left"


6.8.1 (p. 173)

"The name that F# library uses reflects this use, so the function is called List.map_concat."

"map_concat" has been replaced with "collect" in 1.9.6.16
("fold_left" to "fold" was already addressed elsewhere)
Tomas Petricek (160) [Avatar] Offline
#2
Re: Minor typo 6.7.2 (p.169)
Hi,
I've already fixed the last one in the manuscript (when updating everything to work smoothly with latest F# version). I'll fix the two other issues when I'll get the chapter back from copyediting (the next phase on the way to a printed book smilie ).

Thanks for the bug reports!
Tomas