The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

gmartin3 (2) [Avatar] Offline
In the following code snippet from page 12, shouldn't "trips.checkAvailability... " be "mytrips.checkAvailability... " ??

Now let’s look at the implementation code for the TripBooking component, also in the
com.tuscanyscatours package.
public class TripBooking implements Bookings {
protected com.goodvaluetrips.Trips mytrips;
protected Updates cart;
public String newBooking(String trip, int people) {
String resCode = trips.checkAvailability(trip, people); // typo? mytrips?
return “GV” + resCode;
simon.nash (37) [Avatar] Offline
Re: page 12: shouldn't "trips.checkAva..." be "mytrips.checkAva..."?