The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

LGranstedt (2) [Avatar] Offline
#1
The book states on p.223 that "report model data sources can only reference SQL Server 2000 abd above, or Analysis Services 2005". Perhaps that was true when you wrote it, but it is not true today. I'm the lead RS2005 person in my organization & I was tasked with determing whether Report Builder could be used to query an Oracle database. I researched & was able to demonstrate that it could.
johnmichaelpeters (1) [Avatar] Offline
#2
Re: Report model data sources update
Can you be more specific on what Oracle driver you installed on SSRS?

I also would like to know which Oracle Server install you are querying. We have Oracle 10.2 sitting on a AIX OS which sometimes gives us some security challenges.
LGranstedt (2) [Avatar] Offline
#3
Re: Report model data sources update
Hi there,

Since you posted your question two months after my initial post I never noticed it was here. I'll reply in case it still helps you or it might help someone else.

What I have in my notes is that I had to install Oracle instant client - basic and ODBC. (Basic is always necessary). Then I could create a system DSN that tested OK.

I also downloaded and installed the Oracle data provider for .NET (ODP.NET). This turned out to be Oracle DAC 10.2.0.2.21.

Doing the above on my XP workstation enabled the necessary connection to Oracle for development of the report model project in VS2005.

On the RS2005 server I had to install the same so it could connect to Oracle and execute report queries.

This was just a feasibility test but no Oracle reporting was ever put in production. But perhaps the information might be helpful anyway.

/LG
547830 (2) [Avatar] Offline
#4
I actually found out what I needed to get my problem solved, i.e. using the system wide regional settings to format the report numbers: Set the Language property of the report to User!Language.
juegos friv gratis