mcraghead (7) [Avatar] Offline
#1
While it is not an error, in chapter 1, page 5, one example uses:
Emailer emailer = new Emailer();

and example following uses:
Emailer service = new Emailer();

Maybe it was done that way to differentiate between the two examples, but as the reader I see the second example as a re-write of the previous one, so that change in variable names is a little confusing. Maybe I just read it too quickly and got lost for a second, but to me with the second example being a re-write of the earlier one the same names should have been used.

Again, this is not an error, but my perspective as the reader trying to follow along.

Michael K. Craghead
dhanji.prasanna (37) [Avatar] Offline
#2
Re: Chapter 1 - Comment
Yea, I noticed this the other day too! Good point.

I'll fix it in the next draft.
481328 (1) [Avatar] Offline
#3
looking for more information.