The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

Don Stadler (74) [Avatar] Offline
#1
As with the WS-Security Mule example the target exists in the build file but not in the book descriptions. I deployed the targets anyway, then tried to run the example in the test client, with no apparent effect.

I also checked looked for the WS-Addressing targets in the chapter 7 build files, and found a wsa-consume taget in the Mule file, no wsa-provide. And no wsa targets in the Servicemix file at all.

Message was edited by:
Don Stadler
tijs.rademakers (494) [Avatar] Offline
#2
Re: Chapter 7 WS-Security Servicemix example
The output is again shown in the second box in the input panel of the Swing test client, so there you should see the web service responses You're right we only have a wsa-consume example for Mule, and no example for ServiceMix. Mule and ServiceMix both don't have a lot of support for WS-Addressing. For Mule we implemented a short example, but for ServiceMix we didn't. Maybe something for the esbinaction.com website?

Best regards,

Tijs
Don Stadler (74) [Avatar] Offline
#3
Re: Chapter 7 WS-Security Servicemix example
That's actually not surprising, WS-Addressing isn't generally supported despite the fact that it's an elegant solution for a problem which is commonly solved in a butt-ugly fashion.
Don Stadler (74) [Avatar] Offline
#4
Chapter 7 WS-Security Servicemix varying results
I ran the provide target for Servicemix WS-Security, ran the test on the test client and it ran OK. Surprised me a little given the key troubles I had with both Mule examples.

The results of the WS-Security consume example were the same as with WS-Consume. Started the out queue on the test client, then ran the test multipl times with no discernable reaction either in the test client or in the servicemix trace.