rainyglade (9) [Avatar] Offline
#1
When I run build.bat as indicated on p. 20, from the samplesexplorer directory, I get the following:

Loading configuration file C:flex_sdkframeworksflex-config.xml
Error: class org.apache.xerces.util.XMLAttributesMMImpl$AttributeMMImpl cannot access its
superclass org.apache.xerces.util.XMLAttributesImpl$Attribute
..plus a nasty huge stack trace.

I have lots of stuff on my dev. computer, including Apache Ant, Apache Tomcat, Xalan, and other XML Java programs. I have tried versions 1..1, 1.7.0 and 1.6.5 of Ant, but no joy.

Is there a solution to this problem?
rainyglade (9) [Avatar] Offline
#2
Re: Iteration 2 running build.bat n samplesexplorer
One more thing on this. I cleared my CLASSPATH of everything but a required company path to CRM software, and I'm still getting this error.

I also tried moving into the containers subdirectory and typing the command directly:

C:Flex_sdk_3samplesexplorercontainers>......inmxmlc.exe -use-network=fa
lse AccordionExample.mxml

But that didn't work either.

Any suggestions will be appreciated.
rainyglade (9) [Avatar] Offline
#3
Re: Iteration 2 running build.bat n samplesexplorer
Heh, answering my own question. I found the following suggestion:

I'm seeing this bug on Ubuntu 8.04 with Ant 1.7.0 and Flex SDK Version 3.0.1 build 1092. My workaround has been to rename <flex_sdk_home>/libs/xercesPatch.jar to xercesPatch.jar.bak (effectively removing it). This causes mxmlc to throw out a warning, but allows the compile to finish.

at http://bugs.adobe.com/jira/browse/SDK-14519. I tried that and it works!