devert (1) [Avatar] Offline
#1
In iteration 2 where it explains how to install Rails 2.0 it says to run the command "gems install rails -v 1.99.0 -source http://gems.rubyonrails.org"

There are two errors here that needed to be fixed in order for me to get this to work. The version should be just "1.99" without the 0. Also it needs to be "--source", not "-source."

Hopefully they will just update to Rails 2.0 soon, but until then this is how I had to get it to run to install the Release Candidate 1.

Really excited about this book. It is exactly what I have been looking for.
railsguy (2) [Avatar] Offline
#2
Re: Error in Rails 2 RC1 install command
This may just be a problem with my specific machine, but I also had to install rake after installing ruby using the following from the command line:

gem install --remote rake

Then the installation of Rails 2 worked fine (also, notice in prior post that "gems" should be "gem").
railsguy (2) [Avatar] Offline
#3
Re: Error in Rails 2 RC1 install command
Here are the commands I had to use for the installation (after I installed ruby itself)

gem install --remote rake
gem install rails -v 1.99 --source http://gems.rubyonrails.org --include-dependencies
peterarmstrong (94) [Avatar] Offline
#4
Re: Error in Rails 2 RC1 install command
These install commands were a real moving target for me. Thankfully, Rails 2 is finally out so it should settle down a bit. I'll add an updated note during my review of the typesetting...
Jarisha (1) [Avatar] Offline
#5
Re: Error in Rails 2 RC1 install command
I'm just starting the book. I've installed Ruby on my Win XP Pro machine. When i enter "gem install rails" after a few prompts it tells me:
ERROR: While executing gem ... (Gem::Installer::ExtensionBuildError)
ERROR: Failed to build gem native extension.

ruby extconf.rb install rails
checking for fcgiapp.h... no
checking for fastcgi/fcgiapp.h... no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.