The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

prasadbv (1) [Avatar] Offline
#1
Hi ,

I have a report serve at http://MyServer/reportserver
My Asp .net web application is running on anothere machine http://WebappMachine/default.aspx.

Here is what is happening
1.My Report server admin created a folder <<MyName>> and gave me user name and password to acess it .

2.I connect through url http://Servername/reportserver . server prompts me for Username and password . When I key in user name pass word it takes me to the
root . I browsed through to the <<MyNameReports>> and created datasource and uploaded .RDL files.

3.I browse the URL to run reports externally using http://myReportserver/ReportServer/Pages/ReportViewer.aspx?%2fDeveloper%2fmyname%2fReports%2ftestreport&rs:Command=Render

it works .

4. I am developing a web app in Asp .net and use reportviewer control to show the report. Credentials is the same as what I using during manually running the reports .Code is as follows

Me.ReportViewer1.ServerReport.ReportServerCredentials = New System.Net.NetworkCredential(uid, pwd)
Me.ReportViewer1.ProcessingMode = ProcessingMode.Remote
Me.ReportViewer1.ServerReport.ReportServerUrl = New System.Uri("http://myreportserver/reportserver")
Me.ReportViewer1.ServerReport.ReportPath = New String("/myname/Reports/testReport")
Me.ReportViewer1.ServerReport.SetParameters(RptParameters)
Me.ReportViewer1.ServerReport.Refresh()


I get following error .

"The request failed with the error message:
--
<html><head><title>Object moved</title></head><body>
<h2>Object moved to here.</h2>
</body></html>

--."

I tried to use API

Dim rs As New Microsoft.SqlServer.ReportingServices2005.ReportingService2005()
rs.Url = "http://myreportserver/reportserver/ReportService2005.asmx"
rs.Credentials = New System.Net.NetworkCredential(UID, PWD)
rs.LogonUser(UID, PWD, Nothing)

Dim items As CatalogItem() = rs.ListChildren("/Developer/myname/Reports", True)

even this trows the same error as shown above .

Kindly help me this .