The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

Hackboy (4) [Avatar] Offline
#1
Hello!
I writing and run example ch10, but hi is not work!
I not change example and use database Northwind, so i change string connection.
When i input value in textbox i see message: No matching Data

What it's problem?
I not understand!

Help me, please!
Pascarello (208) [Avatar] Offline
#2
Re: Problem with ch10
Did you try debugging the script when it gets to the server? Does it get the information it is supposed to?

Download Firefox and install the extension firebug. That will let you see what is being passed and recieved from the server.

Eric
Hackboy (4) [Avatar] Offline
#3
Re: Problem with ch10
I download firebug. When i run my page html - firebug write - element not fount ^
Default.aspx (line 1).

My default.aspx:
<%@ Page Language="C#" AutoEventWireup="false" CodeFile="Default.aspx.cs" Inherits="_Default" %>

This all!

And i change file typeAhead.html:

//Listing 10.4
window.onload = function(){
var elemSpan = document.createElement("span");
elemSpan.id = "spanOutput";
elemSpan.className = "spanTextDropdown";
document.body.appendChild(elemSpan);
//Listing 10.7
document.Form1.txtUserInput.obj =
SetProperties(document.Form1.txtUserInput,
document.Form1.txtUserValue,'Default.aspx',
true,true,true,true,"No matching Data",false,null);
}
More i not change file from example, except string connect and raname file aspx!

What is problem?
Hackboy (4) [Avatar] Offline
#4
Re: Problem with ch10
Please, help me!
Hackboy (4) [Avatar] Offline
#5
Re: Problem with ch10
Anybody help me!
Pascarello (208) [Avatar] Offline
#6
Re: Problem with ch10
'Default.aspx' should be the name of the page that has the code and not the name of the current page.

Is it possible to zip up the files you are using and attach it.

Eric