kurinosuke (156) [Avatar] Offline
#1
I think I'm going to post all erratas in one post because I'm polluting the forum with loads of little posts. I've gathered the others in this post.

---------------------------------------------------------
- About commands root tag in Chapter 5
Listing 5.15, CommandServlet.java.
The servlet is reading the incoming xml data, looking for the root tag "commands".

I can't figure out where the "commands" tag is being set.
In listing 5.13, CommandQueue object, we set a request parameter called "data" to, appending each command in the queue. So all "command" tags will be concatenated to the "data" request parameter. I can't see where the root tag is being set.

Anything I'm missing, or is it an inconsistency in the sample code ?

Moreover, we are using a ContentLoader in Listing 5.13 with POST method, not specifying the contentType. So it will default to x-www-form-urlencoded. How can we make a Document in Listing 5.15 although the request is not in xml format ? The doPost method seems out of context in this chapter.

---------------------------------------------------------
- Page 211, the head page of chapter 6.
There are four bullets.
The last one is : "Highlighting updated data in situ"
I'm not sure what the complete sentence could be

---------------------------------------------------------
- page 305, Last paragraph, first line.
"In our simple script, this a small and temporary problem" should be "In our simple script, this is a small and temporary problem"

---------------------------------------------------------
- page 309, Fourth paragraph, first line.
"we could alter our remove() method" should be "we could alter our removeBox() method"

Code snippet at the bottom of page:
geElementById should be getElementById

---------------------------------------------------------
- listing page 317, (8.4.2)
In render() function, "this.body.backingObj=this;" is missing.

---------------------------------------------------------
- page 345, Paragraph 9.5.2, first line.
"Moving to a double combo to a triple combo" should be "Moving from a double combo to a triple combo"

---------------------------------------------------------
- page 347, Second line from the top:
"the requestParameters argument" should be "the requestParams argument"

---------------------------------------------------------
- page 374, 2nd line of text.
"called setProperties()" should be "called SetProperties()"

5th line of 2nd paragraph:
The two parameters "ignoreCase" and "matchAnywhere" should be called respectively, "xignoreCase" and "xmatchAnywhere".

---------------------------------------------------------
- page 379, 3rd paragraph, 1st line.
"whether the textbox is using a timer to hide the textbox" should be "whether the textbox is using a timer to hide the span"

---------------------------------------------------------
- Possible Errata page 378

Page 380, line 9, we read :
"The last check is to make sure that the current value's length is greater than the last value.

However, in listing 10.10 page 378, we have:
"|| (theTextBox.value.length <= strLastValue.length)"

Looks like the last check makes sure that the current value's length is shorter than the last value.

---------------------------------------------------------
- page 383, 3rd paragraph, 2nd line.
"We make sure that we set the currentSelectedValue" shoud be "We make sure that we set the currentValueSelected"

---------------------------------------------------------
- Figure 10.4(page 371) and 10.5(page 391) of the type-ahead sample.
Results shown seem strange.
Figure 10.4, looking for 'a', but 'Mix' comes in the list. And some characters are not highlighted (e.g 'Alice'). Same about figure 10.5

---------------------------------------------------------
- page 417, "Creating the pop-up contents", 5th line
"this.updateSugggestionsDiv()" should be "this.updateSuggestionsDiv()"

---------------------------------------------------------
- page 439, 11.4, 3rd paragraph, 4th line
"You can obtain the Javascript library JSWindow.js,".
The file is actually called AJAXWindow.js in the downloadable archive.
It has been renamed, as stated further, in 11.4.3
In fact, the whole chapter is mixing AJAXWindow.js and AjaxWindows.js (with an 's').

---------------------------------------------------------
- page 440, 3rd paragraph, 2nd line from bottom
"You can see in figure 11.10 that we have added three DHTML windows" should be
"You can see in figure 11.11 that we have added three DHTML windows".

---------------------------------------------------------
- page 446, 2nd paragraph, 2nd line
"download the file AjaxWindow.css" should be "download the file AjaxWindows.css"

---------------------------------------------------------
- page 450
First line
"As you can see in listing 11.11" should be "As you can see in listing 11.10"

Third line
"it appends win in front of the number from the database id column" should be
"it appends window_ in front of the number from the database id column"

---------------------------------------------------------
- page 457, listing 11.14's title
"Adapation of the AjaxWindows.js mouse hander" should be "Adapation of the AjaxWindow.js mouse handler"

---------------------------------------------------------
- page 461, "Login", 5th line
"that our load-page command would perform". There's no such command.
Maybe it should be "that our PageLoad command would perform".

---------------------------------------------------------
- page 478, "Building the dynamic XML document", 2nd line from bottom
"and create an entry in the XML file for each phone"
should be "and create an entry in the XML document for each phone"
We are writing an XML document in the response, not a file.

---------------------------------------------------------
- page 500, number 4 Update the bookmark, 3rd line after updateBookmark listing
"The q= parameter with the value of the current search are appended" should be
"The q= parameter with the value of the current search is appended"

---------------------------------------------------------
- page 507, Table 13.2
The optional element "managing editor" should be named "managingEditor"

---------------------------------------------------------
- page 508, Table 13.2
The optional element "webmaster" should be named "webMaster"

---------------------------------------------------------
- page 510, Figure 13.2
"Optain web site RSS file" should be "Obtain web site RSS file"

---------------------------------------------------------
- page 520, 4th paragraph
It is said "The last variable, intLoadFile, leads us into our next section of code".
Listing 13.6's last variable, is bLoadedOnce, not intLoadFile.
bLoadedOnce is not even discussed in 13.3.1, so should be removed from the listing.

---------------------------------------------------------
- page 533, last paragraph before figure 13.11
"since the button btnAdd's text says RESUME" should be "since the button btnPause's text says RESUME"

---------------------------------------------------------
- page 543, figure 13.15
In the code snippet, "Rss Feed" should be "RSS Feed" and "this.nubFeeds" should be "this.numFeeds".

---------------------------------------------------------
- page 544, Figure 13.17
The figure's title should be renamed from "Article (x of y) : RSS Item Title", which is figure 13.16's title, to "RSS Item Content"

---------------------------------------------------------
- page 549, 6th line from top
"_pauseBtn, and addBtn" should be "_pauseBtn, and _addBtn"

---------------------------------------------------------
- page 554, 3rd line after lisintg 13.36
"ID of the reader with the suffix _newsFeeds" shoud be "ID of the reader with the suffix _newFeeds"

FINISHED. This was a very interesting, instructive book. I had to rethink Javascript from scratch, but this was worth it.
Pascarello (208) [Avatar] Offline
#2
Re: My Errata list
Thanks for posting these. Sorry been real busy lately with my job. I have a deadline before I go on my vacation. I really need it!

Eric
kurinosuke (156) [Avatar] Offline
#3
Re: My Errata list
it's ok, I'll try to keep my list up to date. Feel free to update the official errata list when you find some time. Enjoy your holidays