nawrin (1) [Avatar] Offline
#1
hi..

I am a niwebie in 'AXIS' . but i had correctly installed it without any problem
with the help of 'apache.axis.install.pdf' and also tested the examples
under 'samplesuserguide' directoy provided with 'AXIS'.

Later ,I wanted to run a 'build.xml' file created of my own to run the
'example3' project under a diffrent directory and configured the 'build.xml'
accordingly. I succeded but after then .. I could not run any of the examples.

When i tried to run any 'CLIENT' file from command prompt ....

" h:axissamplesstock > java -cp %AXISCLASSPATH%
org.apache.axis.client.AdminClient
-lhttp://localhost:8080/axis/services/AdminService deploy.wsdd

"

It works. but if i run..

h:axissamplesstock > java org.apache.axis.client.AdminClient
-lhttp://localhost:8080/axis/services/AdminService deploy.wsdd


it shows me

''Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/axis/client/AdminClient ''

This is same for all the examples.
I can't anticipate .. what the problem may be. For ur convenience .. i here
provide all the classpaths...


JAVA_HOME H:Javaj2sdk1.5.0
AXIS_HOME H: omcatwebappsaxis
AXIS_LIB %AXIS_HOME%web-inflib


AXISCLASSPATH %AXIS_LIB%axis.jar;
%AXIS_LIB%axis-ant.jar;%
AXIS_LIB%commons-discovery-0.2.jar;
%AXIS_LIB%commons-logging-1.0.4.jar;
%AXIS_LIB%jaxrpc.jar;%AXIS_LIB%saaj.jar;
%AXIS_LIB%log4j-1.2.8.jar;
%AXIS_LIB%xml-apis.jar;
%AXIS_LIB%xercesImpl.jar;
%AXIS_LIB%xmlsec.jar;
%AXIS_LIB%activation.jar;
%AXIS_LIB%mailapi_1_3_1.jar;
H: omcatcommonlibservlet.jar;
%AXIS_LIB%wsdl4j-1.5.1.jar;
%AXIS_LIB%xmlParserAPIs.jar

CLASSPATH .;%AXISCLASSPATH%;h:Javaclasses





It's really urgent for me... i'll be grateful to u if u pls can give any solution .